Can-Am ATV Forum

instrument cluster error

This is a discussion on instrument cluster error within the Can-Am / BRP forums, part of the Can-Am ATV Discussion category; anyone ever heard of this one? dealer plugged quad in to check for updates. now there is the letter d then the 0 in the ...


Go Back   Can-Am ATV Forum > Can-Am ATV Discussion > Can-Am / BRP

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-18-2009, 07:48 PM
Supporting Member
Feedback Score: 0 reviews
 
Member #6128
Join Date: Jan 2009
Location: niagara falls, New York, USA
Posts: 365
Thanks: 0
Thanked 1 Time in 1 Post
View rob13's Photo Gallery(0)
Post

anyone ever heard of this one? dealer plugged quad in to check for updates. now there is the letter d then the 0 in the rpm area and and an F in front of 0 on trip1 and trip2. they can't figure it out
__________________
anyone willing to trade a little freedom for a little safety deserves neither freedom or safety
Reply With Quote
Sponsored Links
Can-AmForum.com is the premier Can-Am ATV, Can-Am Outlander, Can-Am Renegade Forum on the internet. Registered Users do not see these ads. Please Register - It's Free!
   
  #2  
Old 03-22-2009, 11:04 AM
Supporting Member
Feedback Score: 0 reviews
 
Member #6128
Join Date: Jan 2009
Location: niagara falls, New York, USA
Posts: 365
Thanks: 0
Thanked 1 Time in 1 Post
View rob13's Photo Gallery(0)
Post

well dealer is going to replace the instr. cluster for me. they said this was a first. prob. caused by the comp. program or who knows.
__________________
anyone willing to trade a little freedom for a little safety deserves neither freedom or safety
Reply With Quote
  #3  
Old 03-22-2009, 07:30 PM
Voodoo's Avatar
Torn and Twisted!!
Feedback Score: 0 reviews
 
Member #2820
Join Date: May 2007
Location: Winnsboro, LA , USA
Posts: 12,372
Thanks: 0
Thanked 70 Times in 70 Posts
View Voodoo's Photo Gallery(8)
Post

Hey dude...sorry no one answered...I have never heard of that problem, but your dealer is doing the right thing...
__________________
Voodoo


Reply With Quote
  #4  
Old 03-22-2009, 07:42 PM
Supporting Member
Feedback Score: 0 reviews
 
Member #6128
Join Date: Jan 2009
Location: niagara falls, New York, USA
Posts: 365
Thanks: 0
Thanked 1 Time in 1 Post
View rob13's Photo Gallery(0)
Post

no prob. figured i'd let everyone know in case they had this happen. prob. wouldn't effect the quad but it was weird. glad i'm a first for something
__________________
anyone willing to trade a little freedom for a little safety deserves neither freedom or safety
Reply With Quote
Reply

Lower Navigation
Go Back   Can-Am ATV Forum > Can-Am ATV Discussion > Can-Am / BRP


Search tags for this page

204471378 brp cluster

,

can anyone fix suzuki atv instrument cluster

Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Discount Tire
Motosport.com



All times are GMT -6. The time now is 12:18 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.