2013 max dps problem? - Can-Am ATV Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 05-01-2013, 12:34 PM Thread Starter
Senior Member
Feedback Score: 0 reviews
 
Hogaholic's Avatar
 
Join Date: Mar 2013
Location: Virginia
Posts: 145
Thanks: 0
Thanked 5 Times in 5 Posts
2013 max dps problem?

Picked up my new max xtp last weekend, 4 hours into breakin got a check dps message. After reading about others having problems on this forum, I tightened the battery leads and the problem went away. At 7 hours during mild riding I noticed steering getting stiff in turns. Is this normal? If this were race speeds I can see it being a real issue.
Hogaholic is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 05-01-2013, 12:57 PM
Senior Member
Feedback Score: 0 reviews
 
BigHurt's Avatar
 
Join Date: Aug 2012
Location: Indianapolis
Posts: 744
Thanks: 10
Thanked 116 Times in 81 Posts
Quote:
Originally Posted by Hogaholic View Post
Picked up my new max xtp last weekend, 4 hours into breakin got a check dps message. After reading about others having problems on this forum, I tightened the battery leads and the problem went away. At 7 hours during mild riding I noticed steering getting stiff in turns. Is this normal? If this were race speeds I can see it being a real issue.
I would take it to a dealer, you don't want it to "death roll" at high speeds. I have only heard of this happening once on here. Mine through a "Check DPS" message and the power steering didn't work at all, I did a restart and all was fine, I still took it to my dealer and he did see the code! he did some tests and filled my connectors with electrical grease and all is fine. 585 miles and no issues

Shut Up & RIDE
2013 XMR 1000
Muzzy Slip-on / Ceramic & Wrapped
Power Commander
Kore M20 14"Rims
Zillas Tires
Can-Am Luggage Box
Rigid Industries 10" LED light bar
Cycle Sound 2 1/2 150w Stereo System
Rubber Down Shock Spacers
G/P Bushings
American Star Chromoly Heim Tie Rod Ends and Rod
BigHurt is offline  
post #3 of 9 Old 05-01-2013, 07:01 PM
Senior Member
Feedback Score: 0 reviews
 
Join Date: Feb 2012
Location: Sudbury,Ontaio, Canada
Posts: 632
Thanks: 41
Thanked 112 Times in 72 Posts
Sorry to hear your having issues and Big Hurt is right take it in and ask if it has the software update for the DPS. This is another DPS issue even with the new 13's just shows you that BRP is not listening or fixing the issue. This link will answer what your question as to why it got harder to steer on the bottom of page 11 I posted the pages out of the Official Shop Manual that explains how the DPS cuts assist as the DPS motor gets warmer but I think it cuts it too soon
DPS Problems on 2012 Outlander

Mine is in at the dealer as we speak getting the DPS wiring rerouted and some other parts changed so I plan on posting what they did once I get it back if it fixes the DPS issues.

2013 Yellow now CAMO wrapped Outlander 1000 XT
28" Zilla's with ITP Machined 212's
29.5" OL2's on 14' M16
High Lifter Signature Series 1 1/2" lift kit
QSC GEN II Primary
Full Black Dual Muzzy Exhaust and Digituner
Elka Stage 2+R shocks
Garage Products Full Bushing Set
Full set of Ricochet skid plates
ROX 2" Elite Anti-Vibration Risers
Renegade split brake system and PowerMadd hand guards
DP515 & DP516 pads

2012 Black Outlander 1000 XT (sold)

Last edited by nonothing; 05-01-2013 at 08:11 PM.
nonothing is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 05-01-2013, 08:09 PM Thread Starter
Senior Member
Feedback Score: 0 reviews
 
Hogaholic's Avatar
 
Join Date: Mar 2013
Location: Virginia
Posts: 145
Thanks: 0
Thanked 5 Times in 5 Posts
My son picked up his 2013 max ltd at the same time, we rode them tonight, identical problems, after agressive riding for about 20 minutes, it gets hard to steer, and the dps motor is hot to the touch. Both machines were manufactured september 2012. Im a little dissapointed after spending 15k that we are having a problem like this.
Hogaholic is offline  
post #5 of 9 Old 05-01-2013, 08:17 PM
Senior Member
Feedback Score: 0 reviews
 
Join Date: Feb 2012
Location: Sudbury,Ontaio, Canada
Posts: 632
Thanks: 41
Thanked 112 Times in 72 Posts
Quote:
Originally Posted by Hogaholic View Post
My son picked up his 2013 max ltd at the same time, we rode them tonight, identical problems, after agressive riding for about 20 minutes, it gets hard to steer, and the dps motor is hot to the touch. Both machines were manufactured september 2012. Im a little dissapointed after spending 15k that we are having a problem like this.
Man do I feel your pain I'm on my 3rd DPS motor and it still shutdown last ride that's why it's in the shop again. My bike is a year old and I only have just over 400 kms or 250 miles because every big trip my quad is either in the shop or it loses the DPS and I have to go home. I've put 800 kms on my truck going back and forth to the dealer. BRP wake up and start listening. Mine shut the DPS off just starting the bike cold and driving it up on my trailer to go to the dealer not even warmed up.

2013 Yellow now CAMO wrapped Outlander 1000 XT
28" Zilla's with ITP Machined 212's
29.5" OL2's on 14' M16
High Lifter Signature Series 1 1/2" lift kit
QSC GEN II Primary
Full Black Dual Muzzy Exhaust and Digituner
Elka Stage 2+R shocks
Garage Products Full Bushing Set
Full set of Ricochet skid plates
ROX 2" Elite Anti-Vibration Risers
Renegade split brake system and PowerMadd hand guards
DP515 & DP516 pads

2012 Black Outlander 1000 XT (sold)

Last edited by nonothing; 05-01-2013 at 08:51 PM.
nonothing is offline  
post #6 of 9 Old 07-10-2014, 10:40 PM
Junior Member
Feedback Score: 0 reviews
 
Join Date: Jul 2014
Location: Montana Rocky Mountains
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
db_good

I am having the same problem with my 2010 650 max XT. I just turned19hrs on it. Have the Check DPS & engine light on. While sitting in the driveway I pressed the override DPS button and the engine light went off as did the check DPS message. Now I'm really confused. Planning a ride the 119th of July, but can't get it in until the 23rd of July. Will it be ok to ride? Am not overly aggressive while ridding to this point. Thank you all for your great information!
db_good is offline  
post #7 of 9 Old 07-12-2014, 05:20 PM Thread Starter
Senior Member
Feedback Score: 0 reviews
 
Hogaholic's Avatar
 
Join Date: Mar 2013
Location: Virginia
Posts: 145
Thanks: 0
Thanked 5 Times in 5 Posts
Pull all the plugs out of dps and dielectric grease them, check all your power conections, plus ground lugs on right side of bike. Also the biggest thing is to heat wrap your headers.

2013 Outlander Max Xtp, Richochet full skids, Muzzy Digituner, Hmf Swamp XL pipe, Uni-Filter, Race Driven brakes, Tribal LED Whips , Halo Angel Eyes , Ogio Honcho rear storage, Billet shifter, Cobra axles , Amsteel winch cable, ASR Tie Rods. Montana Gp
2013 Outlander Max xtp 1000
1997 Honda Foreman
2006 Yfz 450
2007 Harley Davidson Heritage Classic
2006 Kawasaki kdx 200
Hogaholic is offline  
post #8 of 9 Old 07-13-2014, 01:39 AM
Junior Member
Feedback Score: 0 reviews
 
Join Date: Jul 2014
Location: North Carolina
Posts: 25
Thanks: 2
Thanked 0 Times in 0 Posts
My 2014 outlander does the same thing, and message on the display flashes DPS overtemp and then say goodbye to the power steering. Haven't had a chance to take it back to the dealer yet.
jeh800rxt is offline  
post #9 of 9 Old 07-13-2014, 06:38 AM
Senior Member
Feedback Score: 0 reviews
 
Rockhead's Avatar
 
Join Date: Mar 2013
Location: Middle Earth
Posts: 932
Thanks: 61
Thanked 107 Times in 95 Posts
I have had mine overheat several times. Mostly from rock crawling and muddy conditions. It always comes back after letting it cool for 10 min. It does fade a bit while riding. I had my 2014 on med most of yesterday and high periodically just to see and no issues other than a little fade. The previous ride in similar conditions maybe a little worse it overheated twice at the end of the ride
Rockhead is offline  
Reply

  Lower Navigation
Go Back   Can-Am ATV Forum > Can-Am ATV Discussion > Can-Am Outlander

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
DPS Problem & Solution 2013 Outlander Max Don123 Can-Am Outlander 40 01-20-2015 08:47 AM
2013 Can Am Videos, here's the new line up for 2013! rkc05 Can-Am / BRP 207 08-15-2013 10:34 AM
2013 can-am renegade 1000r problem starting colinobrien11 Can-Am Renegade 14 07-27-2013 12:09 AM
2013 xmr 1000 air box problem THEBUSTER Can-Am XMR 4 04-30-2013 09:56 AM
2013 XMR 1000 Mud Guards... Problem!!! ATVLinda Can-Am XMR 2 10-03-2012 02:42 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome