Here is how to reset/erase the MAINTENANCE REQUIRED message - Can-Am ATV Forum
 5Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 Old 03-16-2019, 08:22 PM Thread Starter
Member
Feedback Score: 0 reviews
 
Join Date: Nov 2018
Location: New Brunswick, Canada
Posts: 62
Thanks: 0
Thanked 4 Times in 4 Posts
Exclamation Here is how to reset/erase the MAINTENANCE REQUIRED message

A lot of people have trouble with the procedure.
The owner manual says to hold the SET button and then toggle HI and LOW beam 3 times then release the SET button.
It's missing some important steps :

1 - Turn ignition ON but don't start the quad.
2 - You HAVE to be on the ODOMETER (total quad mileage) display.
3 - Put HIGH BEAMS ON. (You must start the procedure from HI BEAMS)
3 - Press and HOLD the SET button.
4 - Toggle HI - LOW three times WITHIN 2 SECONDS.
5 - Release SET button.
6 - Turn ignition OFF and wait until the dash goes dark.
7 - Turn ignition back ON, VOILA! MESSAGE GONE.

I think a lot of people can't get it working because step 2 and step 3 are NOT mentioned in the owner manual. It is however mentioned in the SHOP manual:


Last edited by sergemcgraw83; 03-16-2019 at 08:34 PM.
sergemcgraw83 is offline  
The Following User Says Thank You to sergemcgraw83 For This Useful Post:
scoho2098 (03-18-2019)
Sponsored Links
Advertisement
 
post #2 of 17 Old 03-16-2019, 08:26 PM
Senior Member
Feedback Score: 0 reviews
 
Jorge570's Avatar
 
Join Date: Sep 2017
Location: Schoharie, NY
Posts: 640
Thanks: 0
Thanked 30 Times in 30 Posts
Yeah I followed the instructions in the manual. Worked no problem 😁👍🏼

2017 Can-Am Outlander 570DPS

2001 Ski Doo MXZ 700
Jorge570 is online now  
post #3 of 17 Old 03-16-2019, 08:28 PM Thread Starter
Member
Feedback Score: 0 reviews
 
Join Date: Nov 2018
Location: New Brunswick, Canada
Posts: 62
Thanks: 0
Thanked 4 Times in 4 Posts
Quote:
Originally Posted by Jorge570 View Post
Yeah I followed the instructions in the manual. Worked no problem 😁👍🏼
Cool. You probably had it in odometer display and did not realize it.
sergemcgraw83 is offline  
Sponsored Links
Advertisement
 
post #4 of 17 Old 03-16-2019, 09:30 PM
Senior Member
Feedback Score: 0 reviews
 
Outtymax1's Avatar
 
Join Date: Apr 2018
Posts: 124
Thanks: 0
Thanked 2 Times in 2 Posts
Is this on a g2 only? And the set button is the button on the top of the gauge?
Outtymax1 is offline  
post #5 of 17 Old 03-17-2019, 01:39 AM
Senior Member
Feedback Score: 0 reviews
 
A10ThunderboltII's Avatar
 
Join Date: Dec 2012
Location: AZ Winters, Okanagan Summers
Posts: 752
Thanks: 15
Thanked 63 Times in 51 Posts
Quote:
Originally Posted by sergemcgraw83 View Post
A lot of people have trouble with the procedure.
The owner manual says to hold the SET button and then toggle HI and LOW beam 3 times then release the SET button.
It's missing some important steps :..

What YEAR and Model are you running ? I dont think this procedure is specified for older
2013-201 G2s

2013 650 XT Outlander CAMO
A10ThunderboltII is offline  
post #6 of 17 Old 03-17-2019, 05:28 AM
Senior Member
Feedback Score: 0 reviews
 
WIOutty's Avatar
 
Join Date: Oct 2017
Posts: 435
Thanks: 0
Thanked 30 Times in 26 Posts
That worked on my 2017 last year when I did it.
WIOutty is offline  
post #7 of 17 Old 03-17-2019, 06:02 AM Thread Starter
Member
Feedback Score: 0 reviews
 
Join Date: Nov 2018
Location: New Brunswick, Canada
Posts: 62
Thanks: 0
Thanked 4 Times in 4 Posts
Quote:
Originally Posted by A10ThunderboltII View Post
Quote:
Originally Posted by sergemcgraw83 View Post
A lot of people have trouble with the procedure.
The owner manual says to hold the SET button and then toggle HI and LOW beam 3 times then release the SET button.
It's missing some important steps :..

What YEAR and Model are you running ? I dont think this procedure is specified for older
2013-201 G2s
2018 outlander max 850.
Some says the procedure 9nly works on newer quads that have the DESS KEY but I can't test it.

2018 Outlander MAX XT 850 / Yoshimura Slip-On / Monster FI ECU Flash / Elka Stage 3
sergemcgraw83 is offline  
post #8 of 17 Old 03-17-2019, 07:03 AM
Senior Member
Feedback Score: 0 reviews
 
Jorge570's Avatar
 
Join Date: Sep 2017
Location: Schoharie, NY
Posts: 640
Thanks: 0
Thanked 30 Times in 30 Posts
Mine is a ‘17 without the dess. Just followed my owners manual and cleared the message. Easy

2017 Can-Am Outlander 570DPS

2001 Ski Doo MXZ 700
Jorge570 is online now  
post #9 of 17 Old 03-17-2019, 07:12 AM Thread Starter
Member
Feedback Score: 0 reviews
 
Join Date: Nov 2018
Location: New Brunswick, Canada
Posts: 62
Thanks: 0
Thanked 4 Times in 4 Posts
Quote:
Originally Posted by Jorge570 View Post
Mine is a ‘17 without the dess. Just followed my owners manual and cleared the message. Easy
Cool. Mine NEVER worked with the owner manual procedure. I HAD to have it in the odometer display.

2018 Outlander MAX XT 850 / Yoshimura Slip-On / Monster FI ECU Flash / Elka Stage 3
sergemcgraw83 is offline  
post #10 of 17 Old 03-18-2019, 05:05 PM
Junior Member
Feedback Score: 0 reviews
 
Join Date: Sep 2018
Location: Rockburn. Quebec, Canada
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
How would this work without a key to turn on? My 2018 xtp only shows a display if its running. Even waking up the computer by touching the start button leaves the display blank
RogerD31 is offline  
Reply

  Lower Navigation
Go Back   Can-Am ATV Forum > Can-Am ATV Discussion > Can-Am Outlander

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
Maintenance required message 2018 570 XMR BrodyBreaux25 Can-Am XMR 11 01-23-2019 09:22 PM
maintenance required reset flyowyo Can-Am Defender 0 03-09-2018 09:28 AM
Maintenance message removed for 2016? atldude Can-Am 2016 Models 24 04-05-2017 07:47 PM
Maintenance Required Message Mahtee Can-Am Outlander 4 07-05-2016 06:59 PM
No maintenance required message even well past 10hr? dandiele Can-Am Outlander 10 01-07-2016 10:14 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome