Can-Am ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I posted sometime ago about my brand new 800 XMR having issues with only 4 hours on the clock. Well what i thought was just a water pump seal, turned into the dealer ripping apart my motor to find the problem. Long story short, they found out that a thrust washer was not installed from the factory for the water pump shaft. This thing was shooting water out of the weep hole, and was unacceptable for a machine with 4 hours. I have to say that Can-AM as stood beside their product, yes it sucks to be without my wheeler for over a month but they are sending me a brand new engine, which i think is fair for a new machine, i didn't want a rebuilt one. Should be here soon and back in my hands. Can am warranty is good, if its not your own doing. I came off a honda foreman and man that thing took everything i threw at it but was lacking power. I went and looked at the new honda's and ill tell you they seem super tiny and not even as good as my 06 foreman was. Glad i bought the XMR, now once i get it back from the dealer I'm expecting a great powerful machine to make my popo buddy upset:th_smiliedance:
 

·
Registered
Joined
·
2,770 Posts
Congrats on getting everything worked out....will they reset your hours on the xmr to zero since there is a new engine on it? ...
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
No, they did not reset my hours but i have all the paper work for the long block replacement, so if i ever go to sell it that should suffice. I took it out the other day and it runs like a champ! Now those stock brakes were shot and i mean all metal with only 8 hours on the clock. Good thing i read the forum and bought some race driven before i needed them.
 
1 - 4 of 4 Posts
Top