Can-Am ATV Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
2012 CanAm outlander max 650 xt
K&N Filter / intake
Big gun eco slip on
Big gun power box
Warrior riser snorkel
Custom Radiator relocation
28” mudzillas Mounted on can am beadlocks
about 250hrs now ride almost every weekend ,
Bike ran great until last oil change now it won’t start and if it does it’s high idle about 2k-2200 and throwing a cel I only use xps 10w40 and have serviced the bike regularly I’ve had similar issues with the key but it’s not that I’m stumped please help ! I play in water but always clean and electric grease every plug , Bike ran great I changed the oil and filter Next day went for a ride with few friends started the bike all seemed good let her warm up a little put it in High she sputtered and shut off Wouldn’t start for a few seconds then finally fired and seemed fine went on with the ride everything is great the entire ride on the way back home the bike starts acting up again revving high etc I let it cool down for about an hour went out tried to start it and it will fire for a second then just die out I can hear the fuel pump prime every time maybe my IAC ? Or possibly injectors ? PLEASE HELP
 

·
Registered
2015 Outlander XMR 650
Joined
·
3,789 Posts
Welcome to the site.

I think you're on the right track, suspecting the IAC motor. Possibly fuel pump, but I'd deal with the IAC first. Just a random electrical component failure, I don't think the timing of the oil change had anything to do with it. Any check engine lights or codes? I wanna say the IAC should throw a code if it's acting up. You can change it yourself, it should relearn where it needs to sit to control the commanded idle rpm.

Maybe pull it off and see if you can clean any build-up out of it? Oil vapors passing through intake tract just buildup over time, might be making it stick.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Okay thank you ! I will start with pulling the IAC and cleaning It I looked up a oem replacement $130 ouch lol
 

·
Registered
2015 Outlander XMR 650
Joined
·
3,789 Posts
Check with Adept Powersports, they're one of the few companies I know of that sell BRP OEM below list price.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
I will check them out thanks and it is throwing a CEL at 2k-2200 rpm when it wants to run but most of the time it just fires for a second and won’t actually start
 

·
Registered
2015 Outlander XMR 650
Joined
·
3,789 Posts
lol, don't mind B and that anti-K&N talk, he's been trying to talk me out of my K&N too :p

They're supposed to be bad at filtering dust, which is where these machines spend a lot of their time. I've always had success with them, so I'll run 'em until they give me a reason not to :cool:
 
  • Like
Reactions: Wil922

·
Registered
Joined
·
13 Posts
Discussion Starter #9
Haha sounds good yeah where I am dust usually isn’t an issue I’ve always run them on every vehicle I’m able to 🤷‍♂️
 

·
Registered
Joined
·
1,165 Posts
I agree with Bonzo here and don't think i have ever differed in opinion with BomBomb so this is a first. I think for highway use [email protected] are great but back years ago there where lots of pics of filthy intakes from [email protected] filters lots, do a quick google search most i saw were on can am talk. i would check the position sensor and ibv first, if that don't do it id guess fuel pump or speed sensor.
 
  • Like
Reactions: Wil922

·
Registered
2015 Outlander XMR 650
Joined
·
3,789 Posts
don't think i have ever differed in opinion with BomBomb so this is a first.
lol! hey, if we all thought the same things/felt the same way, this world would be a pretty boring place :p 🍻
 

·
Registered
Joined
·
13 Posts
Discussion Starter #12
UPDATE
Cleaned IAC valve idle is back to 1250-1300 but check engine light is still on , i ordered a new IAC so I’ll replace it when it gets here , the bike seems to be running good so I’m not sure why
 

·
Registered
Joined
·
13 Posts
Discussion Starter #13
New OEM IAC installed bike is still throwing a check engine light and won’t run but if I prime the fuel pump with the key a few times the light goes away and the bike will fire up , should I just replace the pump ? Or could anything else cause this i can hear the pump prime every time
 

·
Registered
2015 Outlander XMR 650
Joined
·
3,789 Posts
What's the code?
 
  • Like
Reactions: Wil922

·
Registered
Joined
·
13 Posts
Discussion Starter #15
How do you read the codes ? It’s something I’ve never had to do 🤷‍♂️
 

·
Registered
Joined
·
1,165 Posts
How to check codes with video.

 
1 - 16 of 16 Posts
Top