Can-Am ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1
hey guys bought a rene second hand i finally needed to use the winch on it the other day and i did not work :th_smiliepullhair:

just a clicking noise when i try in or out on the handlebars. its a warn 3500 i believe.
 

·
Registered
Joined
·
18 Posts
solenoid may be bad. I got a 2500 lb warn on my dads quad and if its used a lot in the summer it will get hot and quit working. all you can hear is it clicking when you try to get it to move in or out.
 

·
Registered
Joined
·
38 Posts
Motor is most likely burnt out . I've had 2 replaced on my 2013 xmr first one lasted 3 hrs then 6 months later go to use it and all get is a clicking sound again . Took it to Warn talk to tech he told me even with there sealed motor they still get water inside but have no way to drain . Tech told me to pull motor cover off every once and awhile and clean if riding in a lot of water. Motors are about $ 180.00
 

·
Registered
Joined
·
38 Posts
Motor is most likely burnt out . I've had 2 replaced on my 2013 xmr first one lasted 3 hrs then 6 months later go to use it and all get is a clicking sound again . Took it to Warn talk to tech he told me even with there sealed motor they still get water inside but have no way to drain . Tech told me to pull motor cover off every once and awhile and clean if riding in a lot of water. Motors are about $ 180.00
They should also carry a lifetime warrantee yes no?
 
1 - 4 of 4 Posts
Top