Can-Am ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Out riding today and on 3 occasions I could smell the belt burning. first was on a slow uphill rocky craw in 2 low, 2nd was in a 1 foot deep not very sticky mud hole in 2 low and the 3rd was climbing onto the trailer about a 1 foot climb in 4 low. I did just have the wholesale atv tune and there is a noticeable increase in torque, nothing huge but noticeable. I'm assuming that's why Im having the issue as it. never happened until I got the tune. Want to upgrade to a CV Tech but just can't do it right now. what belt do y'all recomend for the 2020 650. I used a gates carbon on my 570 with good results but I haven't found any listing on the 2020.
 

·
Registered
Joined
·
511 Posts
The tune is not your problem here and will not cause your belt to slip. Stock belt is about the best but gates carbon are good also. If the dealer is close I would take it back for warranty. Sounds like the clutch isn't working correctly. If you are in low you shouldn't have trouble going anywhere. Definitely not on stock tires.

Sent from my Pixel 3 using Tapatalk
 

·
Registered
Joined
·
72 Posts
One sure way to make a belt slip is water. Be sure to check all belt housing bolts. Might have got a "friday" quad.

Sent from my SM-G950U using Tapatalk
 

·
Registered
Joined
·
5,135 Posts
Water, oil, grease.

You can get oil from gearbox or engine, grease from one way.

Take cove off and inspect. Clean with brake clean.

My gates carbon cracked badly at every cog. My gates kevlar exploded into 1000 pieces.

Brp makes a good belt.
 
1 - 4 of 4 Posts
Top