Can-Am ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I own a 2010 Outlander 650 xtp. I keep having overheating issues. it keeps poping the 20amp fan fuse and I can't figure out why. I've blown through all my spare fuses that where in the cover, and had to get more. I'm pretty sure it's only overheating because the fan isn't kicking on. But it keeps poping fan fuses. any help would be great.

FYI, the rad is clean and the fan is free moving and works "when the fuse is good"

[email protected]
 

·
Registered
Joined
·
741 Posts
I own a 2010 Outlander 650 xtp. I keep having overheating issues. it keeps poping the 20amp fan fuse and I can't figure out why. I've blown through all my spare fuses that where in the cover, and had to get more. I'm pretty sure it's only overheating because the fan isn't kicking on. But it keeps poping fan fuses. any help would be great.

FYI, the rad is clean and the fan is free moving and works "when the fuse is good"

[email protected]

Still under warranty??
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
yes, I only had it a few months. My dealer is an hour away though. I was just wondering if I could save a trip. everything with them takes forever, even the ride there. anyone else having this problem?
 

·
Registered
Joined
·
568 Posts
Sound to to me to be a bad fan it might still work but its drawing to many amps see if you can blow it out mayb its got dirt in it
 

·
Registered
Joined
·
92 Posts
x2 on drawing too many amps. Sounds like a bad fan.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
The problem went away. I think water got up in there. Once it sat for awhile and got a good dry on it, I stopped popping fuses. Thus resolving my overheating issue.

brain dead
 

·
Registered
Joined
·
733 Posts
i read some people had got mud/dirt in theirs between the shroud/fan blades causing the fan to stop spinning resulting it blown fuses to anyone else troubleshooting
 
1 - 7 of 7 Posts
Top