Can-Am ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter #1
Hey guys I get a 2014 XT was wondering if anyone knows where the brake light switch connector is. was at the dealer had a tuner pipe installed and had all the brakes done and now I know I don't have brake lights and when I'm in gear and hold the breakdown I can no longer override to start any help would be helpful if not I'll bring it back to the dealer. Thanks.
 

·
Registered
Joined
·
1,847 Posts
Possibilties incude the connector got disconnected for the pressure sensor or broke a wire to same. Or the pressure sensor is broke. The pressure sensor is located on the rear brake master cylinder down by the foot brake. The conncector is about 10 inches above. I had a broken wire where the wires entered the sensor and it cause d the symptoms you describe.
 

·
Registered
Joined
·
85 Posts
Discussion Starter #3
Awesome thanks for the info. When I'm back on Friday I'll have a look.
 

·
Registered
Joined
·
24 Posts
There is also a connector under the seat that's sends a signal from the brake being pressed... If you've never used it before for a cargo box with a light installed then it likely has its factory dust cover on it... If water got in it it could have or be causing a short.... Check that plug and then check fuses for brake light also :) good luck friend
 

·
Registered
Joined
·
1,847 Posts
If it was shorted, the brake line would be on and the brake override start function would work.
 

·
Registered
Joined
·
2,227 Posts
Broken wire on switch down by the foot brake. Take it back to the dealer and have them install the pressure switch on their dime.
 

·
Registered
Joined
·
85 Posts
Discussion Starter #7
Ok thanks a lot for a the info guys. Very helpful I will have a look at the quad when I'm back in town on Friday and more then likely have the dealer fix it as it was working before I dropped it off. Again thanks for the help
 
1 - 7 of 7 Posts
Top