Can-Am ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Renegade 650 XXC 2018 ABS
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Please I need help with fix cold start isue.
1.After first starting, the engine RPM are unstable 650-1400 and after 10s engine switches off.
2.After the second start the engine will not stop, but the rpm are still unstable until the engine warms up.
Dealer replaced throttle body, replaced fuel pump, replaced spark plugs, reset TPS, replaced ECU, checked oil pump pressure, checked timming.. check valves...
The problem is in the summer but also in the winter.
Can anyone advise me please what could cause bad starts?
 

·
Registered
2015 Outlander XMR 650
Joined
·
3,811 Posts
Welcome to the site, that's an interesting one.....

Any error codes at all, while it's stumbling and stalling?

Did they replace the IAT-P sensor? IAC valve operating properly?

How old are the spark plugs/ wires?
 

·
Registered
Renegade 650 XXC 2018 ABS
Joined
·
4 Posts
Discussion Starter #3 (Edited)
Welcome to the site, that's an interesting one.....

Any error codes at all, while it's stumbling and stalling?

Did they replace the IAT-P sensor? IAC valve operating properly?

How old are the spark plugs/ wires?
Thank you very much for your reply.
Any fault codes, spark plugs we replaced last time 10mth ago, without changes. The unit have only 3500km and this isue is here from the beginning.
Dealer replaced also complete Air Intake Manifold And Throttle Body IAT-P sensor, throttle body ass"y, and spark wires
101221
 

·
Registered
2015 Outlander XMR 650
Joined
·
3,811 Posts
Well dang..... they covered a lot of bases.....

I'm reaching here, at this point.... I mean you can take a good long look at the crank pos sensor, maybe pull the injectors and have them flow-benched....
 
  • Like
Reactions: Chief...

·
Registered
2017 850 XTP
Joined
·
39 Posts
I had cold start problems on a new 2017 850XTP where the bike would start then go into a low unstable idle. It sounded like it was running on one cylinder. If i touched the throttle it would pop and stall. Then a long crank hard start and again run like crap till it warmed up.

I winter camp with mine and was getting worried about morning cold starts with a new atv starting this way in the cold.

These bikes run very lean for emissions to start with and my theory is the more oxygen dense colder air of winter leans them out even more and makes the problem worse.

I had my ECU tuned by Monster FI and SOLVED the cold weather starting on my 850.

90% better cold starts with no low idle swings and sounding like its running on one cylinder anymore. Still slow to warm up but runs nice.

There might not be anything wrong with your atv. Try a tune. Its the best thing I ever did to my Outtie. Monster was great to help with with my questions.
 

·
Registered
Renegade 650 XXC 2018 ABS
Joined
·
4 Posts
Discussion Starter #6
Skanko thx for reply and information.
Yes I think this is good/only one idea, but we have several identical models in the group (without Tune),
and mine is the only one that has this problem, so we tried to upload a map from other unit but it remained unchanged.
Yes, an "individual" fuel map for mine unit (Tune) can help, but it does not reveal the fault but only hides the symptom.
If there is nothing wrong with the unit then this product is simply shit :)
I can't imagine that the new Mercedes would work like this ... :) After starting it died down and the factory would say it's normal.

Yes.. There will probably be only one solution ... Tune it

Good old models ... :)



Thank you very much. (y)
 

·
Registered
2017 850 XTP
Joined
·
39 Posts
They should start in the cold weather correctly but some do not. The extra fuel added in my Monster FI tune made a huge difference to cold start and it might help yours. Best modification so far and the mid range is stronger too.
 

·
Registered
Renegade 650 XXC 2018 ABS
Joined
·
4 Posts
Discussion Starter #8
Mine start badly also in hot weather, yes maybe tune can help. Thank you. ✌
 
1 - 8 of 8 Posts
Top