Can-Am ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Haven't posted here in awhile but I finally found the issue why my check engine light keeps coming on at random moments. I have a 2008 Renegade 800 and I had no issues until I started taking it into deep water... thankfully I figured out about pulling the P-CODES with the simple little trick on the gauge cluster; however pulling the code wasn't as easy as it is supposed to be. Whenever I tried to pull the code, it would stay on the screen for a millisecond and they it would say NO ACTIVE P-CODES, so I decided to use my phone and take a video and pause it at the right moment. I came up with the code P0335, which translates to "Crank Pos SensorA Circ Error". I searched all over for anyone else having the same problem with their Can Am, however I found no results. Have any of you guys experienced this specific error code before? And also what is your opinion on fixing this?

I'll also provide a picture with the code.
 

Attachments

·
Registered
Joined
·
410 Posts
H
 

·
Registered
Joined
·
687 Posts
If its happening every time you submarine your machine Id say your getting water into the plug.
 

·
Registered
Joined
·
1,179 Posts
I would clean out the sensor connection and put a little di-electric grease in it and see if it happens again. :smilietwocents:
 
  • Like
Reactions: 33147

·
Registered
Joined
·
2,227 Posts
I had a similar problem with my trans position sensor wires. readout would say P and I would be rollin' down the trail, then would show a different letter like L and I would be in High. Eventually would go into limp mode. Took apart the sensor wires, greased them, all better...
"I put that shit on everything " lol
 
  • Like
Reactions: 33147
1 - 6 of 6 Posts
Top