Can-Am ATV Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
Alright guys I got a question. My 08 outlander 800 fuel gauge doesn't work. They old guy I bought it from said it just didn't work one day when he went out and got on it. It only has 400 miles so I can't see it being worn out or anything. The fuel light blink and it shows no bars. Is there troubleshooting things I can do. Or suggestions to get it to work
 

·
Registered
Joined
·
933 Posts
They are notorious for this. From what I've gathered it would be hard to find one that does work.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #4
Anyway to test that. Would I have to buy the whole fuel pump assembly
 

·
Registered
Joined
·
222 Posts
Don'trun out and buy the whole assembly. IIt's probably just the float. The floats are junk on these. It happened to mine and I found on the forum someone modified their float rod to accept a Ford ranger float. I did it to mine and showed my dealer how to do it as he had 2 units in the shop with bad gas gauges. He did a little work for me in trade. Just search the forum for Ford fuel float that should bring up something for you. The thread had lots of good pics.
 

·
Registered
Joined
·
222 Posts
Mine doesn't work perfect. It still has about 1/3 tank when it's empty but work good enough for me. Only cost me $14 for the Ford ranger float too.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #8
Hmm can't find it on here
 

·
Registered
Joined
·
933 Posts
My search results found a Polaris ranger fuel float.
 
1 - 11 of 11 Posts
Top