Can-Am ATV Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
hello all, my 2016 Outlander 570 left me stranded on my elk hunt!!! ran great, then started smelling gas, and had no power in low speed, Barely would move, backfire from exhaust and engine. Will idle fine, but when you engage the throttle it will die or backfire. Every once in a while, it will get up to speed and then run fine at 25mph or above, when you back out of throttle it backfires and wont get back up to speed. it is also dumping fuel....the ride that usually takes 1/4 tank dropped almost 3/4 tank.. reaks of gas..... thx in advance for any diagnostics, hope to get back to hunt!!!
 

·
Super Moderator
2015 Outlander XMR 650
Joined
·
5,360 Posts
Welcome to the site

When's the last time you changed the plugs?
 

·
Super Moderator
2015 Outlander XMR 650
Joined
·
5,360 Posts
It could be an injector(s) issue, but without spark, you'll also get all of those symptoms. Plus, they're super cheap and easy to change.

Next up after plugs would be to confirm your fuel system pressure, make sure the pump isn't failing. It's much more likely one of those two are the issue, than your injector(s), imo
 

·
Registered
2017 Can-Am Outlander 570 Pro
Joined
·
174 Posts
change the spark plugs for irridium ones , they last longer and runs better
 

·
Registered
Joined
·
8 Posts
In your experience could that cause the issue? I am NOT familiar with ATVs obviously, but pretty capable with car repair and have never seen or heard of spark plugs causing the significant issues and fuel dump like I am having. BUT you folks have been kind to offer advice that i am grateful for. Will try the plugs. Any good videos on removing all the plastic on the Outlander to expose the motor…… afraid of snapping off the clips. Thx again for your help!! Pete
 

·
Super Moderator
2016 Can-Am Outlander Max XT 650
Joined
·
1,186 Posts
Any good videos on removing all the plastic on the Outlander to expose the motor…… afraid of snapping off the clips.
These should help you out. Good luck.
 
  • Like
Reactions: BombardierBomb

·
Registered
Joined
·
8 Posts
Thank you sir!!!! Well spark plugs didn’t do it….. so against my better judgment I am buying a $300 fuel pump hoping that works…… need to get back on the road..
 

·
Super Moderator
2015 Outlander XMR 650
Joined
·
5,360 Posts
Check out Quantum. ~$100 and lifetime warranty. Don't overspend on OE
 

·
Registered
Joined
·
8 Posts
Well, I hear ya, I am in a bind and they have one!! If it’s not the pump, I am out the money!! No returns…..
 

·
Super Moderator
2015 Outlander XMR 650
Joined
·
5,360 Posts
Next up after plugs would be to confirm your fuel system pressure
Don't just go throwing money/parts at it. Borrow an EFI system pressure test kit from your local auto parts store. You should ~51psi fuel pressure out of these systems
 

·
Registered
Joined
·
8 Posts
Well, that would have been the best idea!! Unfortunately I am a moron and don’t always do the best thing!! I really appreciate your quick and helpful responses!!! I may be asking for more of them! 😀😀
 
1 - 16 of 16 Posts
Top