Can-Am ATV Forum banner

Odometer not on or not working on brand new Can Am Outlander

4316 Views 6 Replies 4 Participants Last post by  Bulltender
So i was waiting for a part for the tachometer for 6wks and it showed up last week and i picked up my new 650 max xt. So the weather lately was crap and didn’t want to break it in yet. So i went for a trip out on the lake today and really got confused why the machine got up to 4,000 rpm and didn’t shift. I was told not to go over 4,000 rpm until 5 hrs of driving during break in period. So that was not the rest of the issue. The speed did not show on the display and kilometres was not showing. I assumed this is the tachometer chip or something is not installed as they told me? In any case i guess i will return the machine before i damage it. I can not get any mode up on the screen either. So i have no idea what this display and machine should be doing.
See less
So i was waiting for a part for the tachometer for 6wks and it showed up last week and i picked up my new 650 max xt. So the weather lately was crap and didn’t want to break it in yet. So i went for a trip out on the lake today and really got confused why the machine got up to 4,000 rpm and didn’t shift. I was told not to go over 4,000 rpm until 5 hrs of driving during break in period. So that was not the rest of the issue. The speed did not show on the display and kilometres was not...
See more
1 - 7 of 7 Posts

· Super Moderator
Joined
·
2,223 Posts
These machines don't shift per say. The clutches do shift but you aren't going to see a drop in rpms like a car.

The speedometer thing, just take it back to the dealer. It should be right from the get go.

Sent from my SM-G991U using Tapatalk
 

· Registered
2020 Can Am Defender 6x6
Joined
·
2,229 Posts
There is a recall on some 2022 Outlander 570's, doesn't sound exactly like the problem your having, but might be worth check it out. Your dealer should be able to determine if your ride is one of the affected by the VIN. Speedometer Inaccuracy - Risk of crash (brp.com)
 

· Regular Joe
2014 Maverick 1000r
Joined
·
8,242 Posts
Welcome to the site.

VSS is primarily responsible for odometer/speedometer readings. Yours might be faulty or unplugged or the tip is obscured with break-in shavings. Should be a simple fix

CPS would drive the tach
 

· Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
Welcome to the site.

VSS is primarily responsible for odometer/speedometer readings. Yours might be faulty or unplugged or the tip is obscured with break-in shavings. Should be a simple fix

CPS would drive the tach
Brought it back to the dealer and was quite pissed that the part that i was waiting for 6 wks showed up and never got installed so they say? Speedo sensor? Amazing that the dealer can forget to install it since that was the reason i could not get the machine to start with. Thanks for your response.
 

· Super Moderator
Joined
·
2,223 Posts
That is bs the speed sensor hile would be leaking oil....

Sent from my SM-G991U using Tapatalk
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top