Can-Am ATV Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
winch wired to solenoid , wires and fuse ran up to battery but not connected yet in/out switch mounted, wires ran down to solenoid green and black wires connected. Plug from harness connected to wire down in left side in extra wire, their is a extra hot in case you have heated grips, then a 3 prong and a male and female green plugs battery connected and it don’t work?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
Need some divine guidance I followed the you-tube but it don’t work it’s a 2020 570 and a2500 can am winch
 

·
Registered
Joined
·
647 Posts
Tough and painful to read. Left right up down green black, no punctuation, sentence structure is bizarre, etc. I took this as a challenge, and read it almost a dozen times. Impossible to understand. Sounds like you should pay someone to do the install.

The secret to writing well, for the bare minimum of giving others a chance to understand you is reading quality books.
 

·
Registered
2021 Can-Am Outlander 450
Joined
·
11 Posts
If I understand this convoluted mess correctly, you are expecting the winch to work but you haven't hooked it up to the battery yet?
 

·
Registered
Joined
·
647 Posts
I'll add that I installed a CanAm 2500 winch and had no problems. If the OP is so befuddled installing this, I would recommend installing it on a bench. Hook everything up, out in the open, then attach a battery. That should allow you to see and diagnose the problem without the bike getting in the way.
 

·
Registered
Joined
·
647 Posts
I guess he got it working. This site is notorious for having new members with 1 or 2 posts, never hearing from them again with issues left hanging.
 
1 - 6 of 6 Posts
Top